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Introduction to MS-Excel 

MS-EXCEL is a part of Microsoft Office suite software. It is an electronic spreadsheet with 

numerous rows and columns, used for organizing data, graphically represent data(s), and 

performing different calculations.  It consists of 1048576 rows and 16384 columns, a row and 

column together make a cell. Each cell has an address defined by column name and row 

number example A1, D2, etc. this is also known as a cell reference.  

Cell references: The address or name of a cell or a range of cells is known as Cell reference. 

It helps the software to identify the cell from where the data/value is to be used in the 

formula. We can reference the cell of other worksheets and also of other programs.  

 Referencing the cell of other worksheets is known as External referencing.  

 Referencing the cell of other programs is known as Remote referencing.  

There are three types of cell references in Excel:   

1. Relative reference. 

2. Absolute reference. 

3. Mixed reference. 



 

The Ribbon in MS-Excel is the topmost row of tabs that provide the user with different 

facilities/functionalities. These tabs are: 

 

1. Home Tab: It provides the basic facilities like changing the font, size of text, editing the 

cells in the spreadsheet, autosum, etc. 

2. Insert Tab: It provides the facilities like inserting tables, pivot tables, images, clip art, 

charts, links, etc. 

3. Page layout: It provides all the facilities related to the spreadsheet-like margins, 

orientation, height, width, background etc. The worksheet appearance will be the same in 

the hard copy as well. 

4. Formulas: It is a package of different in-built formulas/functions which can be used by 

user just by selecting the cell or range of cells for values. 



5. Data: The Data Tab helps to perform different operations on a vast set of data like 

analysis through what-if analysis tools and many other data analysis tools, removing 

duplicate data, transpose the row and column, etc. It also helps to access data(s) from 

different sources as well, such as from Ms-Access, from web, etc. 

6. Review: This tab provides the facility of thesaurus, checking spellings, translating the 

text, and helps to protect and share the worksheet and workbook. 

7. View: It contains the commands to manage the view of the workbook, show/hide ruler, 

gridlines, etc, freezing panes, and adding macros. 

Creating a new spreadsheet:  

In Excel 3 sheets are already opened by default, now to add a new sheet :  

 In the lowermost pane in Excel, you can find a button. 

 Click on that button to add a new sheet. 

 

 We can also achieve the same by Right-clicking on the sheet number before which you 

want to insert the sheet. 

 Click on Insert. 



 

 Select Worksheet. 

 Click OK. 

 



Opening previous spreadsheet:  

On the lowermost pane in Excel, you can find the name of the current sheet you have opened.  

On the left side of this sheet, the name of previous sheets are also available like Sheet 2, Sheet 

3 will be available at the left of sheet4, click on the number/name of the sheet you want to 

open and the sheet will open in the same workbook. 

For example, we are on Sheet 4, and we want to open Sheet 2 then simply just click on Sheet2 

to open it. 

 

Managing the spreadsheets:  

You can easily manage the spreadsheets in Excel simply by : 

 Simply navigating between the sheets. 



 

 Right-clicking on the sheet name or number on the pane. 

 Choose among the various options available like, move, copy, rename, add, delete etc.  

 You can move/copy your sheet to other workbooks as well just by selecting the workbook 

in the To workbook and the sheet before you want to insert the sheet in Before sheet. 

 

To save the workbook: 

1. Click on the Office Button or the File tab. 

2. Click on Save As option. 

3. Write the desired name of your file. 



4. Click OK. 

To share your workbook: 

1. Click on the Review tab on the Ribbon. 

2. Click on the share workbook (under Changes group). 

3. If you want to protect your workbook and then make it available for another user then 

click on Protect and Share Workbook option. 

4. Now check the option “Allow changes by more than one user at the same time. This also 

allows workbook merging” in the Share Workbook dialog box. 

5. Many other options are also available in the Advanced like track, update changes.  

6. Click OK. 

Ms-Excel shortcuts: 

1. Ctrl+N: To open a new workbook. 

2. Ctrl+O: To open a saved workbook. 

3. Ctrl+S: To save a workbook. 

4. Ctrl+C: To copy the selected cells. 

5. Ctrl+V: To paste the copied cells. 

6. Ctrl+X: To cut the selected cells. 

7. Ctrl+W: To close the workbook. 

8. Delete: To remove all the contents from the cell. 

9. Ctrl+P: To print the workbook. 

10. Ctrl+Z: To undo. 

Inserting a row 

You can insert a row in a spreadsheet anywhere you need it. Excel moves the existing rows 

down to make room for the new one. 

To insert a row: 

 Click anywhere in the row below where you want to insert the new row. 



 Choose Insert Rows from the menu bar. 

 

 

 A new row is inserted above the cell(s) you originally selected. 

OR 

 Click anywhere in the row below where you want to insert the new row. 



 Right-click and choose Insert from the shortcut menu. 

 

 

 The Insert dialog box opens. 

 

 

 Choose Entire Row. 

 Click OK. 



 A new row is inserted above the cell(s) you originally selected. 

 

 

Select multiple rows before choosing Insert to add rows quickly. Excel inserts the same 

number of new rows you originally selected. 

Inserting a column 

In Excel, you can insert a column anywhere you need it. Excel moves the existing columns to 

make room for the new one. 

To insert a column: 

 Click anywhere in the column where you want to insert a new column. 



 Choose Insert Columns from the menu bar. 

 

 

 A new column is inserted to the left of the existing column. 

OR 

 Click anywhere in the column where you want to insert a new column. 



 Right-click and choose Insert from the shortcut menu. 

 

 

 The Insert dialog box opens. 

 

 

 Click Entire Column in the Insert dialog box. 

 Click OK. 



 A new column is inserted to the left of the existing column. 

 

 

You can also select multiple columns before choosing Insert to add columns quickly. Excel 

inserts the same number of new columns you originally selected. 

Deleting columns and rows 

Columns and rows are deleted in much the same manner as inserting columns and rows. 

To delete a row and all information in it: 

 Select a cell in the row to be deleted. 

 Choose Edit Delete from the menu bar. 



 Click Entire Row in the Delete dialog box. 

 

 

 Click OK. 

To delete a column and all information in it: 

 Select a cell in the column to be deleted. 

 Choose Edit Delete from the menu bar. 



 Click Entire Column in the Delete dialog box. 

 

 

 Click OK. 

Challenge! 

 In column A, type the following names in cells A1, A2, A3, and A4, 

respectively: 

 

Mary in cell A1 

Bob in cell A2 

Susan in cell A3 

John in cell A4 

 In column B, type the following numbers next to each name entered in column 

A: 

 

44 in cell B1 to the right of Mary's name 

28 in cell B2 to the right of Bob's name 



36 in cell B3 to the right of Susan's name 

89 in cell B4 to the right of John's name 

 Insert a column between columns A and B. Type the following numbers in the 

new column B: 

 

76 in cell B1 to the right of Mary's name 

57 in cell B2 to the right of Bob's name 

29 in cell B3 to the right of Susan's name 

61 in cell B4 to the right of John's name 

 Insert a row between rows 2 and 3. Type the following numbers in the new 

row 3: 

Rick in cell A3 

45 in cell B3 

58 in cell C3 

Change the column width or row height in Excel 

You can manually adjust the column width or row height or automatically resize columns and 

rows to fit the data. 

 

Change the column width or row height in Excel 

You can manually adjust the column width or row height or automatically resize columns and 

rows to fit the data. 

Note: The boundary is the line between cells, columns, and rows. If a column is too narrow to 

display the data, you will see ### in the cell. 



Resize rows 

1. Select a row or a range of rows. 

2. On the Home tab, select Format > Row Width (or Row Height). 

3. Type the row width and select OK. 

Resize columns 

1. Select a column or a range of columns. 

2. On the Home tab, select Format > Column Width (or Column Height). 

3. Type the column width and select OK. 

Automatically resize all columns and rows to fit the data 

1. Select the Select All button  at the top of the worksheet, to select all columns and rows. 

2. Double-click a boundary. All columns or rows resize to fit the data. 

IMPLEMENTING FORMULAS IN EXCELL 

Enter a formula that contains a built-in function 

1. Select an empty cell. 

2. Type an equal sign = and then type a function. For example, =SUM for getting the total sales. 

3. Type an opening parenthesis (. 

4. Select the range of cells, and then type a closing parenthesis). 

5. Press Enter to get the result. 

Overview of formulas in Excel 

Get started on how to create formulas and use built-in functions to perform calculations and 

solve problems. 



Create a formula that refers to values in other cells 

1. Select a cell. 

2. Type the equal sign =. 

Note: Formulas in Excel always begin with the equal sign. 

3. Select a cell or type its address in the selected cell. 

 

4. Enter an operator. For example, – for subtraction. 

5. Select the next cell, or type its address in the selected cell. 

 

6. Press Enter. The result of the calculation appears in the cell with the formula. 

See a formula 

1. When a formula is entered into a cell, it also appears in the Formula bar. 

 

2. To see a formula, select a cell, and it will appear in the formula bar. 

 



Enter a formula that contains a built-in function 

1. Select an empty cell. 

2. Type an equal sign = and then type a function. For example, =SUM for getting the total 

sales. 

3. Type an opening parenthesis (. 

4. Select the range of cells, and then type a closing parenthesis). 

 

5. Press Enter to get the result. 

generating series in excel 

Excel SEQUENCE function 

The SEQUENCE function in Excel is used to generate an array of sequential numbers such as 1, 

2, 3, etc. 

It is a new dynamic array function introduced in Microsoft Excel 365. The result is a dynamic 

array that spills into the specified number of rows and columns automatically. 

The function has the following syntax: 

SEQUENCE(rows, [columns], [start], [step]) 

Where: 

Rows (optional) - the number of rows to fill. 

Columns (optional) - the number of columns to fill. If omitted, defaults to 1 column. 

Start (optional) - the starting number in the sequence. If omitted, defaults to 1. 

https://www.ablebits.com/office-addins-blog/excel-dynamic-arrays-functions-formulas/#dynamic-array-functions
https://www.ablebits.com/office-addins-blog/spill-excel-tutorial/


Step (optional) - the increment for each subsequent value in the sequence. It can be positive or 

negative. 

 If positive, subsequent values increase, creating an ascending sequence. 

 If negative, subsequent values decrease, producing a descending sequence. 

 If omitted, the step defaults to 1. 

The SEQUENCE function is only supported in Excel for Microsoft 365, Excel 2021, and Excel 

for the web. 

Basic formula to create a number sequence in Excel 

If you are looking to populate a column of rows with sequential numbers starting at 1, you can 

use the Excel SEQUENCE function in its simplest form: 

To put numbers in a column: 

SEQUENCE(n) 

To place numbers in a row: 

SEQUENCE(1, n) 

Where n is the number of elements in the sequence. 

For example, to populate a column with 10 incremental numbers, type the below formula in the 

first cell (A2 in our case) and press the Enter key: 

=SEQUENCE(10) 



The results will spill in the other rows automatically. 

 

To make a horizontal sequence, set the rows argument to 1 (or omit it) and define the number 

of columns, 8 in our case: 

=SEQUENCE(1,8) 

 

If you'd like to fill a range of cells with sequential numbers, then define both 

the rows and columns arguments. For instance, to populate 5 rows and 3 columns, you'd use this 

formula: 



=SEQUENCE(5,3) 

 

To start with a specific number, say 100, supply that number in the 3rd argument: 

=SEQUENCE(5,3,100) 

 

To generate a list of numbers with a specific increment step, define the step in the 4th argument, 

10 in our case: 

=SEQUENCE(5,3,100,10) 

 



Translated into plain English, our complete formula reads as follows: 

 

SEQUENCE function - things to remember 

To efficiently do a sequence of numbers in Excel, please remember these 4 simple facts: 

 The SEQUENCE function is only available with Microsoft 365 subscriptions and Excel 2021. In 

Excel 2019, Excel 2016 and earlier versions, it does not work since those versions do not support 

dynamic arrays. 

 If the array of sequential numbers is the final result, Excel outputs all the numbers automatically 

in a so-called spill range. So, be sure you have enough empty cells down and to the right of the 

cell where you enter the formula, otherwise a #SPILL error will occur. 

 The resulting array can be one-dimensional or two-dimensional, depending on how you 

configure the rows and columns arguments. 

 Any optional argument that is not set defaults to 1. 

How to create a number sequence in Excel - formula examples 

Though the basic SEQUENCE formula does not look very exciting, when combined with other 

functions, it takes on a whole new level of usefulness. 

Make a decreasing (descending) sequence in Excel 

To generate a descending sequential series, such that each subsequent value is less than the 

preceding one, supply a negative number for the step argument. 

For example, to create a list of numbers starting at 10 and decreasing by 1, use this formula: 

https://www.ablebits.com/office-addins-blog/excel-dynamic-arrays-functions-formulas/#spill-range
https://www.ablebits.com/office-addins-blog/spill-error-excel-fix/


=SEQUENCE(10, 1, 10, -1) 

 

Force a two-dimensional sequence to move vertically top to bottom 

When populating a range of cells with sequential numbers, by default, the series always goes 

horizontally across the first row and then down to the next row, just like reading a book from left 

to right. To get it to propagate vertically, i.e. top to bottom across the first column and then right 

to the next column, nest SEQUENCE in the TRANSPOSE function. Please note that 

TRANSPOSE swaps rows and columns, so you should specify them in the reverse order: 

TRANSPOSE(SEQUENCE(columns, rows, start, step)) 

For example, to fill 5 rows and 3 columns with sequential numbers starting at 100 and 

incremented by 10, the formula takes this form: 

=TRANSPOSE(SEQUENCE(3, 5, 100, 10)) 

To better understand the approach, please have a look at the screenshot below. Here, we input all 

the parameters in separate cells (E1:E4) and create 2 sequences with the below formulas. Please 

pay attention rows and columns are supplied in different order! 

Sequence that moves vertically top to bottom (row-wise): 

https://www.ablebits.com/office-addins-blog/excel-transpose-function/


=TRANSPOSE(SEQUENCE(E2, E1, E3, E4)) 

Regular sequence that moves horizontally left to right (column-wise): 

=SEQUENCE(E1, E2, E3, E4) 

 

Create a sequence of Roman numbers 

Need a Roman number sequence for some task, or just for fun? That's easy! Build a regular 

SEQUENCE formula and warp it in the ROMAN function. For example: 

=ROMAN(SEQUENCE(B1, B2, B3, B4)) 



Where B1 is the number of rows, B2 is the number of columns, B3 is the start number and B4 is 

the step. 

 

Generate an increasing or decreasing sequence of random numbers 

As you probably know, in new Excel there is a special function for generating random 

numbers, RANDARRAY, which we discussed a few articles ago. This function can do a lot of 

useful things, but in our case it cannot help. To generate either an ascending or descending series 

of random whole numbers, we'll be needing the good old RANDBETWEEN function for 

the step argument of SEQUENCE. 

For example, to create a series of increasing random numbers that spills in as many rows and 

columns as specified in B1 and B2, respectively, and start at the integer in B3, the formula goes 

as follows: 

=SEQUENCE(B1, B2, B3, RANDBETWEEN(1, 10)) 

https://www.ablebits.com/office-addins-blog/excel-randarray-function-generate-random-numbers/
https://www.ablebits.com/office-addins-blog/random-number-generator-excel/#Excel-RANDBETWEEN-function


Depending on whether you want a smaller or bigger step, supply a lower or higher number for 

the second argument of RANDBETWEEN. 

 

To make a sequence of decreasing random numbers, the step should be negative, so you put 

the minus sign before the RANDBETWEEN function: 

=SEQUENCE(B1, B2, B3, -RANDBETWEEN(1, 10)) 

 



 

 

Support for Office 2013 has ended 

Upgrade to Microsoft 365 to work anywhere from any device and continue to receive support. 

Upgrade now 

Try-it!Transcript 

Create a chart (graph) that is recommended for your data, almost as fast as using the chart wizard 

that is no longer available. 

Create a chart 

1. Select the data for which you want to create a chart. 

2. Click INSERT > Recommended Charts. 

3. On the Recommended Charts tab, scroll through the list of charts that Excel recommends 

for your data, and click any chart to see how your data will look. 

If you don’t see a chart you like, click All Charts to see all the available chart types. 

4. When you find the chart you like, click it > OK. 

5. Use the Chart Elements, Chart Styles, and Chart Filters buttons, next to the upper-right 

corner of the chart to add chart elements like axis titles or data labels, customize the look of 

your chart, or change the data that is shown in the chart. 

https://www.microsoft.com/microsoft-365/buy/compare-all-microsoft-365-products?ocid=cmmf1xwl0sr
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6. To access additional design and formatting features, click anywhere in the chart to add 

the CHART TOOLS to the ribbon, and then click the options you want on 

the DESIGN and FORMAT tabs. 

Excel Charts 

In Excel, a chart is a tool used to communicate data in visual representation. Charts are usually 

used to analyze trends and patterns in data sets. Excel provides 12 types of charts, and each one 

has different features that make them better suited for specific tasks. Pairing a chart with its 

correct data-style will make the information easier to understand, enhancing the communication 

within your small business. 

For example, if you have been recording the sales figures in Excel for the past few years, then 

using charts, you can easily tell which year had the most sales and which year had the least. You 

can also draw charts to compare set targets against actual achievements. 

How to Create a Chart in Excel? 

Follow the following steps to create a chart in Excel: 

Step 1: Select the data for which you want to create a chart. 

 

Step 2: Click on the Insert tab and go on the recommended Charts option. 

On the Recommended Charts tab, scroll through the list of charts that Excel recommends for 

your data. If you don't see a chart you like, click All Charts to see all the available chart types. 

https://www.javatpoint.com/excel-tutorial


 

Step 3: Select the chart type according to your data and click on the Ok button. 

 

Step 4: Use the Chart Elements, Chart Styles, and Chart Filters buttons next to the upper-right 

corner of the chart to add chart elements like axis titles or data labels, customize the look of your 

chart, or change the data is shown in the chart. 

 



Step 5: To access additional design and formatting features, click anywhere in the chart to add 

the CHART TOOLS to the ribbon, and then click the options you want on 

the DESIGN and FORMAT tabs. 

Types of Excel Charts 

Different scenarios require different types of charts. Excel provides different types of charts that 

suit your requirements. The type of chart that you choose depends on the type of data that you 

want to visualize. To help simplify things for the users, Excel 2013 and above has an option that 

analyses your data and makes a recommendation of the chart type that you should use. You can 

also change the chart type later. 

Below are some of the most commonly used Excel charts and when you should consider using 

them. 

1. Column Chart 

The column chart is the most commonly used chart. It is best used to compare information or 

have multiple categories of one variable, for example, multiple products or genres. 

A Column Chart typically displays the categories along the horizontal axis and values along the 

vertical axis. To create a column chart, arrange the data in columns or rows on the worksheet. A 

column chart has the following sub-types: 

o Clustered Column 

o Stacked Column 

o 100% Stacked Column 

o 3-D Clustered Column 

o 3-D Stacked Column 

o 3-D 100% Stacked Column 

o 3-D column 



 

 

2. Line Chart 

Line charts can show continuous data over time on an evenly scaled axis. Therefore, they are 

ideal for showing trends in data at equal intervals, such as months, quarters, or years. The lines 

connect each data point so that you can see how the values increased or decreased over a while. 

o In a Line chart, category data is distributed evenly along the horizontal axis. 

o And the value data is distributed evenly along the vertical axis. 

To create a Line chart, arrange the data in columns or rows on the worksheet. A-Line chart has 

the following sub-types: 

o Line 

o Stacked Line 

o 100% Stacked Line 

o Line with Markers 

o Stacked Line with Markers 



o 100% Stacked Line with Markers 

o 3-D Line charts 

 

3. Pie Chart 

Pie charts show the size of items in one data series, proportional to the sum of the items. The 

data points in a pie chart are shown as a percentage of the whole Pie. Each value is represented 

as a piece of the Pie so you can identify the proportions. To create a Pie Chart, arrange the data 

in one column or row on the worksheet. A Pie Chart has the following sub-types: 

o Pie 

o 3-D Pie 

o Pie of Pie 

o Bar of Pie 

 



 

. Doughnut Chart 

A Doughnut chart shows the relationship of parts to a whole. It is similar to a Pie Chart, with the 

only difference that a Doughnut Chart can contain more than one data series, whereas a Pie Chart 

can contain only one data series. 

A Doughnut Chart contains rings, and each ring representing one data series. To create a 

Doughnut Chart, arrange the data in columns or rows on a worksheet. A Doughnut Chart has the 

following sub-types: 

o Doughnut 

o Exploded Doughnut 



 

4. Bar Chart 

Bar Charts illustrate comparisons among individual items. In a Bar Chart, the categories are 

organized along the vertical axis, and the values are organized along the horizontal axis. 

The main difference between bar charts and column charts is that the bars are horizontal instead 

of vertical. You can often use bar charts interchangeably with column charts. 

However, some prefer column charts when working with negative values because it is easier to 

visualize negatives vertically on a y-axis. 

To create a Bar Chart, arrange the data in columns or rows on the worksheet. A Bar Chart has the 

following sub-types: 

o Clustered Bar 

o Stacked Bar 

o 100% Stacked Bar 

o 3-D Clustered Bar 

o 3-D Stacked Bar 

o 3-D 100% Stacked Bar 



 

Insert a new object into an Excel sheet 

The Insert Object resides inside the Insert tab of the Excel menu bar. From here, you can insert 

an object and embed/link an external file data to an Excel sheet. Follow the steps to learn the 

process of inserting a new object to an Excel sheet. 

Step 1: Open a new Excel sheet on which navigate to the Insert tab of the Excel bar. 



 

Step 2: Here, select the Text dropdown option and click the Object in the list. 

 

A panel for creating a new object will open. Remember that - only the file type offered inside the 

Create New tab can be embedded in an Excel sheet. 



Step 3: Inside the Create New tab, choose a file type. We have chosen the Microsoft Word 

Document from the Object Type list. 

 

Step 4: Mark the Display as icon so that only the embed file icon will display instead of entire 

file. Now, click OK to close it. 



 

"You can also change the icon by clicking the Change icon button." 

Step 5: A new Word document will create automatically. Enter the data here, whatever you want 

to put and press the Ctrl+S key to save the file. 



 

The Word document is saved as Document in product details. Here, product details is the name 

of the Excel file for which this document is created. 

Step 6: Now, close the embedded Word file and go back to the Excel sheet. You see an icon has 

been inserted to the Excel file for the created document. 



 

Now, double-tap this icon to directly open the linked/embedded word file to it from here. After 

that, one can make changes to it. This Word document is not available outside this Excel file. It 

is only for this Excel file. So, you cannot access this file directly without open the Excel file in 

which the Word file is embedded. 

Insert an existing object into an Excel sheet 

In the previous method, we have inserted (embedded) a new object of Word document type into 

an Excel sheet. This time, we have an existing object created earlier. So, we will insert an 

existing object to an Excel sheet. 

Follow the steps to learn the method to insert an existing object to an Excel sheet. 

Step 1: Open a new Excel sheet on which navigate to the Insert tab of the Excel bar. 



 

 

Step 2: Here, select the Text dropdown option and click the Object in the list. 

 



Step 3: This time, switch to the Create From File tab and click the Browse button on it to insert 

an existing file to the sheet. 

 

Step 4: Browse a Microsoft Word file in your local storage and select it, then click Insert. 



 

Insert as an icon 

Step 5: The selected file link has been inserted. Now, mark the Display as icon and click OK to 

close the panel. 



 

Step 6: Your selected file has been embedded to the Excel file that is displaying as an icon right 

now. 

 



 

Step 7: To see the content of the embedded file, double-tap on the icon to open it. The embedded 

document will open and show you as like below. 



 

When you insert a document using object, Excel provides direct access to that file. You can open 

the file directly from the Excel sheet and even edit the content inside that source file (embedded 

file). 

Excel Filter Function 

The filter option is one of the frequently used features of Excel. Users commonly filter out the 

data using Auto Filter and in more complex data problems with Advanced Filter. Though these 

methods are fast and powerful, they are not dynamic. In simple terms, these methods are not 

updated automatically whenever there is any change in the original data. Therefore, you would 

have to remove the filter, change the data, and apply the filter again. This way, it is very time-

consuming. 

To prevent this drawback, Excel introduced the long-awaited alternative, i.e., the FILTER 

function in Excel 365. Unlike the previous methods, the Excel FILTER() function 



recalculates the data automatically with each worksheet change, easing your task, as now 

you only need to set up your filter once! 

What is Filter Function? 

The Excel FILTER function is used to filter the range or array of values based on the given 

criteria. This function returns an output containing an array of values from the original range that 

automatically spills into a range of cells, beginning from the excel cell where you enter the Filter 

function. 

The FILTER function generates dynamic output. When the values in the original data change or 

if the size of the original data array alters, the FILTER function automatically updates the output. 

Further, the result from this function will "spill" onto the Excel sheet into various cells. The 

Filter function belongs to the group of Dynamic Arrays functions. 

The primary role of the FILTER function is to extract the matching values from a given data set 

by supplying one or more logical tests (or criteria). Logical tests are applied using the 'include' 

parameter, and it can hold various types of formula criteria. For instance, FILTER can match 

data in a specific employee sheet and fetch all the employee names whose sales figures are less 

than 350000 INR (or any other specified threshold value). 

Syntax 

=FILTER(array, include, [if_empty]) 

Parameters 

o Array (required) - This parameter represents the range of cells or the array of values in 

Excel worksheet that you wish to filter. 

o Include(required) - This parameter represents the criteria that you want to apply to your 

array. It can be provided as a Boolean array (TRUE and FALSE values). 

For example, (B2:B6)>2 is a Boolean criterion where we have mentioned that the filter 

function should only extract data from range B2: B6 if their value is greater than 2. 

o If_empty(optional) - This argument represents the value to return when none of the 

criteria is met. Typically it includes a customized user message such as "No values 



found", but you can supply other values as well. You don't pass any value in this 

parameter, it will take an empty string ("") as the default value and will return nothing. 

Points to Remember for Excel FILTER function 

Below given are some important points that will help you to apply the FILTER function in your 

Excel worksheets effectively: 

o The FILTER function analyzes the criteria and, based on the criteria it automatically 

spills the output horizontally or vertically, depending on how your source data is 

arranged in the Excel worksheet. So, always remember to have sufficient empty cells 

down and to the right of the cells; otherwise, Excel will throw a #SPILL error. 

o The FILTER function generates dynamic output, meaning the values in the original 

data change, or if the size of the original data array changes, the FILTER function will 

automatically update the output. However, the range provided for the parameter 'array' is 

not updated when new values are added to your original data. But if you want to resize 

the array argument automatically, you must convert it to an Excel table or create a 

dynamic named range. 

Example 1: Filter out the student's name from the below Excel table, where student's score is 

greater than 50. 

 

Follow the below steps to solve the above problem: 

Step 1: Select a cell 



Select a cell where you want to put your filter data. Always make sure to have enough empty 

cells towards the right and bottom of your selected cell, as it could value multiple values based 

on your original data. 

As you can see in the below image, here we have selected cell E5. 

 

Step 2: Type the formula i.e., =Filter( 

After you select the blank cell (E5), just type the formula: = Filter( 

It will look similar to the below image: 

 

Step 3: Enter the range of cells or array you wish to transpose 

The next step is to type (or select) the range of the cells or array you want to filter. Although 

instead of typing you can point and drag your mouse cursor to select the group of original cells. 



In this example, the original cells are positioned from B4 to 9. Therefore our formula 

becomes: =FILTER (B4: C9. It will look similar to the below image: 

 

Step 4: Enter the criteria 

We will move to the next argument (criteria) so firstly we will put a comma (,). Here, we need to 

filter the names of students whose score is greater than 50. So our criteria is Score (range of 

cells) > 50. 

In this example, the score cells are positioned from C4 to C9. Therefore our formula 

becomes: =FILTER (B4: C9, C4:C9 > 50. It will look similar to the below image: 



 

Step 4: Fill value in the third argument (though this step is optional) 

In this argument we will type a customized user message such as "Sorry! No records found", but 

you can supply other values as well. If you don't pass any value in this parameter, it will take an 

empty string ("") as the default value and will return nothing. 

Therefore our formula becomes: =FILTER (B4: C9, C4:C9 > 50, "Sorry! No records 

found"). It will look similar to the below image: 

 

Step 5: Press enter and Excel will give the filtered output 

As soon as you press the enter button, you will have the filtered records in front of you. 

In our case, we have three fields where the score is greater than 50. And we have received the 

same three fields. 



 

How to sort in Excel? 

Sorting of data is an essential part of data analysis. In Excel, you can rearrange the data by 

sorting to find the record quickly. Data can be sorted in various ways, such as alphabetically (A 

to Z, Z to A), highest to lowest, lowest to highest, date & time-wise, and using many other ways. 

Sorting of data is always required for quick search; it arranges the data in a way that makes the 

data easy to search. If the data is sorted, it is easy to find any record in the table or Excel sheet. It 

saves the time of users by fast search in sorted data. Excel provides an in-built function named 

as SORT() to arrange the data in sorted manner. 

This chapter will define how one can sort data in Excel. 

How can be the different data sorted? 

o The text data can be sorted alphabetically, i.e., A to Z or Z to A. 



o Numeric data can be sorted by range, i.e., highest to lowest or lowest to highest. 

o Date and Time wise, i.e., newest to oldest or oldest to newest. 

You can follow any of the techniques to sort your Excel data. In an Excel sheet/table, you 

can sort one or more columns. For example, sort the employee table records, first by their 

salaries and then their last n How to sort in Excel? 

Here, we will define you how one can sort data in Excel. Excel provides SORT function to 

arrange the data in a manner. You can manually sort the table data by entering the formula and 

providing the required parameters. Otherwise, Excel offers shortcuts to sort the data of Excel. 

First, we will describe you what a sort() function is, then will show you the steps to sort the data 

by taking different examples. 

What is sort() function? 

SORT() is a function that is used in Excel to sort the columns and arrange the table data. It 

allows the users to sort the data alphabetical, numeric, or date-wise. You can also make the 

group and then apply this sort() function to these groups individually. 

By default, it sorts the data of an Excel table in ascending order using the first column. 

Syntax 

Here is the syntax for the following sort() function having four parameters, in which one is 

permanent and the other three are optional: 

1. =SORT(array, [sortIndex], [sortOrder], [byColumn])   

Parameters 

array: It is a range or array in an Excel table selected for sorting. 
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[sortIndex]: It is an optional parameter. In this parameter, specify the column number for sorting 

the table data. Its default value is 1, which means it choose first column of the Excel table. 

[sortOrder]: It is also an optional parameter. Using this parameter, you can specify the order of 

sorting. Its default value is also 1 means ascending order sorting. 

Pass 1 for ascending order sorting and -1 for descending order sorting. 

[byColumn]: It indicates either sorting by column or by row. Its default value is FALSE. 

TRUE - Sort by column 

FALSE - Sort by row 

Return Value 

The sort() function returns the array after sorting the data. 

Implementation of sort() formula (For Excel 365 subscription users) 

Now, we will show you how you can implement this formula in your Excel sheet. But this can 

only be implemented by Excel 365 subscription users. In Excel 2016, 2019, this way of sorting 

does not work. We have another method for this discussed in this chapter below. 

Step 1: We have this set of data containing Name and Age data in unsorted order. We will use 

the sort() function and rearrange it. 



 

Ascending Order Sorting 

Step 2: On the Excel home page, go to the formula bar and type this sort() formula to get the 

data sorted with respect to the Age column. 

1. =SORT(A2:B8, 2, 1)   

o Here, A2:B8 are the source/range of array for sorting 

o 2 is the specified column2 (Age) for sorting 

o 1 is ascending order of sorting 



 

Step3: Now, press the Enter key and see the sorted result has been automatically pasted into 

new cells (D and E). 



 

Descending Order Sorting 

In this example, we will sort the Excel data by Name alphabetically in descending order. 

Step 1: On the Excel home page, go to the formula bar and type this sort() formula to get the 

data sorted with respect to the Name column. 

1. =SORT(A2:B8, 1, -1)   

o Here, A2:B8 are the source/range of array for sorting 

o 1 is the specified column1 (Name) for sorting 

o -1 is descending order of sorting 



 

Step 2: Now, press the Enter key and see the sorted result has been automatically pasted into 

new cells (D and E). 



 

Excel Sort() function tip 

o Currently, the sort() function cannot be manually typed and accessed in all Excel 

versions. It is only available for Microsoft 365 subscriptions. 

o Excel 2016, 2019 does not support the sort() function. However, these versions have 

another way to use this formula from the Excel ribbon, which is discussed below in this 

chapter. 

o If you will try to access this formula in other Excel except Microsoft 265, it will show 

this error. 



 

Sort the Data from Excel ribbon (For all Excel) 

It is not possible to remember all formulas of Excel and their parameters every time. So, Excel 

also provides one more way to use these formulas. Besides this method, we will also describe 

other ways of using the sort() function to sort the Excel data. 

Excel has added some most needed formulas in its ribbon for fast and easy access, which is 

efficient for the non-excel user. Use any of them which you find simple and easy. Here, we have 

several examples using different parameter values. 

Steps to sort the entire table data 

We have a simple data Excel table with two columns, name and age. Data of the table is not 

arranged yet. Now, we will sort this table of data with respect to the Name column 

alphabetically. 

Sort by text 

Here, we will sort the entire table data by a text string. We have few simple steps to sort the data 

alphabetically. 

Step 1: Create a table, same as ours or open your existing Excel sheet whose data you want to 

sort. 



 

Step 2: Select all data of the sheet to sort the entire Excel sheet using one column value. It means 

that when column values sort, its associated column data will also be sorted. 



 

Step 3: Now, navigate to the Data tab in the Excel menu bar, where you will get a Sort function 

option in Sort & Filter group. 

Click on this Sort option that will open a popup dialogue box. 



 

Step 5: In this dialogue box, specify/select a column from the list on the basis of which you want 

to sort the data. For Example, Product to sort the table. 

 



Step 6: Specify the order of sorting either A-to-Z or Z-to-A and click on the OK button. We will 

select ascending order (A-to-Z). 

 

Step 7: See that the entire table data has been sorted successfully according to your chosen 

column (Product) and order of sorting. Their associated row data also sorted. 



 

Sort only one column 

Sometimes, you only need to sort a single column data, but you do not want to entire table data. 

So, we will show one column can be sorted. Remember that sorting one column is easy than 

sorting the entire table. 

Step 1: Open your existing Excel sheet to sort the data and select a column that you want to sort. 



 

Step 2: Navigate to the Data tab in the Excel menu bar, where you will get the Sort function 

option. 



 

Step 3: If you want to sort in lowest to highest sorting order, click on the A-to-Z sorting 

button to sort. 



 

Step 4: If you want to sort in lowest to highest alphabetical sorting order, click on the Z-to-A 

sorting button. 



 

Step 5: A popup dialogue box will open when you select the order of sorting, as shown below. If 

you want to expand the sorting and rearrange the entire table data, mark the Expand the 

selection option. 

 

Step 6: If you want to sort only selected column data, mark the Continue with the current 

selection option. 



 

This time, we will sort only a single column value. So, we will select the Continue with the 

current selection option in this dialogue box and click on the Sort button here. 

 

Step 6: See the below screenshot; only selected column values have been sorted (A-to-Z order), 

and rest of the column data remained the same. 



 

Sort by Number 

Excel not only allows to sort the data alphabetically; it also allows to sort the table data using 

numeric data column data as well. So, we will sort data by number now. The process of sorting 

an Excel sheet using the number column is almost the same as sorting a table using string 

parameter. The means that it is almost the same as text sorting. 

The following are some simple steps to sort the data by number, either in ascending or 

descending order. 

Step 1: Create a table, same as ours or open your existing Excel sheet whose data you want to 

sort. 



 

Step 2: Select the numeric data column to sort that column data as well as the associated column 

with it. This means the entire table data will be sorted. For example, we will sort this table data 

based on the quantity of purchased products. 



 

Step 3: Now, navigate to the Data tab in the Excel menu bar, where you will get a Sort function 

option in Sort & Filter group. 

Click on this Sort option that will help to find the values quickly by sorting the data. 



 

Step 5: A dialogue box will open and ask either to expand the selection or continue with the 

current selection. Here, mark the Expand the selection radio button and click on the Sort button 

below. 

 

Step 6: Another dialogue box will show where specify/select a column from the list on the basis 

of which you want to sort the data. For Example, Quantity to sort the table. 



 

Step 6: Now, choose the order of sorting either smallest to largest or largest to smallest from the 

list and click on the OK button. We will select descending order (largest to smallest). 

 

Step 7: See that the entire table data has been sorted successfully according to your chosen 

column (Product) and order of sorting. Their associated row data also sorted. 



 

Other columns have also been sorted with the selected column data in descending order of 

quantity purchased. 

Create a Worksheet in Excel 

MS Excel or Microsoft Excel is one of Microsoft's most powerful spreadsheet software. It comes 

with a distinct range of built-in features and functions to help us record large amounts of data in 

a worksheet. By default, whenever we create a new workbook in Excel, we get three worksheets, 

namely Sheet 1, Sheet 2, and Sheet 3. However, there may be cases when we may need one or 

more additional worksheets to record our data. Excel also provides such a useful option or 

feature to the users. 



This article discusses various step-by-step tutorials on creating a worksheet in Excel. Before 

discussing the process of creating a worksheet in Excel, let us briefly discuss the Introduction to 

Excel worksheet. 

What is a Worksheet in Excel? 

An Excel worksheet is the single sheet used in Excel documents, which contains groups of cells 

organized in rows and columns. Each worksheet allows users to record or write data within the 

cells as well as perform various operations with the recorded data. 

The worksheets are located in the bottom area of the Excel window, which is known as the Sheet 

tab. The new workbook has the following sheets by default: 



 

We have three worksheets in the Sheet tab in the above image, such as Shhet1, Sheet2, and 

Sheet3. To view any of the desired worksheets, we need to click on the name of that particular 

sheet from the Sheet tab. 



How to create/ insert a worksheet in Excel? 

In Excel, we have multiple ways to perform the most common tasks. Likewise, when it comes to 

creating a worksheet, we can use different methods, such as: 

o Creating a worksheet using the Sheet tab 

o Creating a worksheet using the Contextual Menu 

o Creating a worksheet using the Ribbon 

o Creating a worksheet using the Keyboard Shortcuts 

o Creating a worksheet using VBA 

Let us discuss each method in detail: 

Creating a worksheet using the Sheet tab 

The easiest method to create a worksheet within the workbook is to use the Sheet tab. Excel 

displays an additional Plus icon in the Sheet tab, called the 'Add/Insert Worksheet button' in 

general. We can instantly create a worksheet in our Excel workbook using this plus icon or 

button. Also, clicking this icon multiple times allows us to create multiple worksheets 

accordingly. 

 

As soon as we click the plus icon in the Sheet tab, a new worksheet is created to the right-most 

side of the last worksheet name. By default, the worksheet names are created in sequential order. 



For example, if we have three worksheets, such as Sheet1, Sheet2, and Sheet3, in our workbook 

and click the plus icon, the newly created worksheet will be named Sheet4. 

 

Creating a worksheet using the Contextual Menu 

The contextual menu refers to the right-click menu options accessed on the corresponding 

feature. It is another easy method to create a worksheet in the workbook. We can follow the steps 

discussed below: 



o First, we need to press the right-click button on any sheet name on the Sheet tab to open 

the contextual menu. 

 



o Next, we need to click on the 'Insert' option from the list, as shown below: 

 

o As soon as we click the Insert option, Excel launches the Insert dialogue box. We must 

choose the Worksheet option and click the Ok button to create a new worksheet and 

close the dialogue box. 



 

The new worksheet is created instantly in the active Excel workbook, as shown below: 

 

When we use this method, the new worksheet is created on the left side of the selected sheet 

instead of the most-last sheet in the Sheet tab. Thus, we must select the worksheet carefully when 

pressing the right-click button. Besides, the naming approach is the same. We can use this 

method again and again for each additional worksheet like other methods. 



Creating a worksheet using the Ribbon 

Excel is a feature-rich spreadsheet software, and most of the features are placed on the Ribbon. 

Accessing the ribbon tools is one of the basic tasks of Excel. The Ribbon also allows us to use 

the tool to create a worksheet. We can perform the following steps to create a worksheet using 

the Ribbon within our Excel workbook: 

o First, we need to go to the Home tab on the Ribbon. 

 



o Next, we need to click the drop-down icon associated with the Insert option in the 

category named Cells. 

 

o In the next window, we must choose the Insert Sheet option, as shown below: 

 

As soon as we click the Insert Sheet, the same will be immediately created on the left side 

of the selected sheet in our Excel workbook by following the sequential naming 

approach. 



 

Also, we can perform the above steps many times to create more worksheets, 

respectively. 

Creating a worksheet using the Keyboard Shortcuts 

Excel has many built-in or predefined keyboard shortcuts that help quickly perform most tasks. 

We can also create a new worksheet within our Excel workbook using the keyboard shortcut. 

Excel has two different keyboard shortcuts to create a worksheet quickly without using the 

mouse. We can either use Shift + F11 or Alt + Shift + F1. However, we may need to use the Fn 

function key for some keyboards to activate function keys, such as F1, F2, … so on. 

 

To use the keyboard shortcut for creating a worksheet, we can perform the following steps: 

o First, we need to select any sheet from the Sheet tab. 

o Next, we need to press and hold the Shift key on the keyboard. 

o While holding the Shift key, we must press and release the F11 Lastly, we must release 

the Shift key. The new worksheet will be created quickly. 



When we use the keyboard shortcut to create a worksheet in our workbook, the sheet is inserted 

to the left side of the selected or active sheet. Also, creating multiple worksheets is possible with 

keyboard shortcuts. 

 

Creating a worksheet using VBA 

VBA (Visual Basic for Applications) is one of the advanced features of Excel that allows us to 

perform most of the tasks using code. While creating a worksheet, Excel offers us to execute a 

simple macro or script through VBA to create the worksheet at the desired location in the Sheet 

tab. 

We can perform the below steps to create a worksheet using VBA in Excel: 



o First, we need to launch the VBA editor using the keyboard shortcut Alt + F11. 

 

o Next, we need to go to Insert > Module and paste the following code in the module 

editor window. 

1. Sub Add ()   

2.     Sheets.Add   

3. End Sub   

The above code will look like the following image: 



 

o After copy-pasting the code in the module window, we must execute/ run the code using 

the F5 As soon as we execute the code, the new worksheet is created to the left side of 



the active sheet within the workbook. 

 

Similarly, when we need to create a worksheet after any specific sheet in the Sheet tab, we can 

use the following code: 

1. Sub Add ()   

2.     Sheets.Add After:=Sheets("SheetName")   

3. End Sub   

In the above code, we have to specify the existing worksheet name, after which we want to 

create a worksheet in place of SheetName. 

How to create multiple worksheets in Excel? 

Although we can use any of the above-listed methods multiple times to create multiple sheets 

within the workbook, it will be a lengthy process. Besides, Excel also allows us to insert multiple 

worksheets at once. To create many sheets at once, we typically need to select or highlight the 

same number of existing worksheets to notify Excel how many we require. 

When selecting worksheets in Excel, we need to follow below rules: 



o When we need to select a single worksheet, we can click on its name from the Sheet tab. 

o When selecting multiple contiguous (or adjacent) worksheets, we must first click on the 

first sheet, hold down the Shift key and then click on the last sheet from the Sheet tab. In 

this way, we can select all the worksheets between the first and last clicked sheets. 

o When we need to select multiple contiguous worksheets to the right side of the active/ 

selected sheet, we can use the keyboard shortcut Ctrl + Shift + PgDn for each new 

worksheet. Besides, we can use the shortcut Ctrl + Shift + PgUp to select the worksheets 

to the left side of the active sheet. 

o When selecting multiple non-contiguous (non-adjacent) worksheets, we need to click on 

each sheet name from the Sheet tab while holding the Ctrl 

o We can select the 'Select All Sheets' option from the contextual menu to select all 

worksheets in an Excel workbook. However, this particular method is not helpful when 

hiding worksheets in Excel. 

After selecting the desired number of worksheets, we can create a worksheet using the 

Contextual Menu, Ribbon, or Keyboard Shortcuts. 

Example: Creating 3 Contiguous Worksheets in Excel 

Let's suppose that we have a newly created workbook with default worksheets, such as Sheet1, 

Sheet2, and Sheet3. We want to create three more worksheets in our workbook. To do this, we 

must go through the following steps: 



o First, we need to select the first worksheet from the Sheet tab. 

 

o Next, we must press and hold down the Shift key on the keyboard. 

o While holding the Shift key, we need to click on the last sheet, i.e., Sheet3, from the 

Sheet tab. This will select all three worksheets of the workbook. Once multiple 

worksheets are selected in the workbook, it displays the text as 'Group' on the top of the 



Excel window, as shown below: 

 



o Once all three default worksheets are selected, we can go through the Home > Insert > 

Insert Sheet 

 

o As soon as we click the 'Insert Sheet' option, the three new worksheets are created within 

the same workbook, as shown below: 



 

Similarly, if we want to create six more worksheets, we can use the keyboard shortcut 

again after selecting all the existing six worksheets. 

In this way, we can quickly create multiple worksheets in a few clicks. 
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